В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
Gregorie
Gregorie
04.06.2020 23:11 •  Информатика

Нужно) паскаль авс дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова в алфавитном порядке

Ответ:
Математик094
Математик094
07.10.2020 22:08
uses crt;
var s,s1:string;    
a:array[1..100] of string;    
n,i,j,k:byte;
begin
clrscr;
writeln('Введите текст из слов, разделенных пробелами');
readln(s);
s:=' '+s+' ';{добавим пробел в начало и в конец}
n:=length(s);
i:=2; k:=0;{всего слов}
while i<=n do
if (s[i]<>' ')and (s[i-1]=' ') then{если не пробел а перед ним пробел}  
begin  
k:=k+1;{+ слово}  
j:=i;  
s1:='';  
while (j<=n) and (s[j]<>' ') do {пока не пробел и не конец строки}    
begin    
s1:=s1+s[j];    
j:=j+1;    
end;  
a[k]:=s1;{пишем его в массив}  
i:=i+length(s1);{перешагиваем через слово}  
end
else
i:=i+1;{пропускаем пробелы}
for i:=1 to k-1 do {сортируем массив по возрастанию=по алфавиту}
for j:=i+1 to k do if a[i]>a[j] then  
begin  
s1:=a[i];  
a[i]:=a[j];  
a[j]:=s1  
end;
writeln('Слова текста в алфавитном порядке:');
for i:=1 to k do
writeln(a[i]);
readln
end.
0,0(0 оценок)
Ответ:
knoposhka123
knoposhka123
07.10.2020 22:08
Var s: string;
begin
  readln(s);
  writeln(s.ToWords.Sorted.JoinIntoString(' '));
end.

это строка для проверки
для проверки строка это
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?