В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Янаvi
Янаvi
19.02.2022 16:45 •  Информатика

Составить программу с++: записать функцию вычисления модуля числа n modul (n) и использовать ее для вычисления среднего арифметического модулей трех произвольных чисел.

Ответ:
Yulia1393
Yulia1393
07.10.2020 21:46
/*VS C++*/
#include <iostream>
using namespace std;

double modul(double n) {
    if (n < 0) return -n;
    else return n;
}

int main() {
    double a = modul(-100);
    double b = modul(100);
    double c = modul(-25);
    cout << (a + b + c) / 3 << endl;
    system("pause");
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?