Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Нукку95
27.09.2022 19:42 •
Информатика
Дан массив действительных чисел, размеренность которую n. подсчитать, сколько в нем отрицательных, положительных и нулевых элементов 9 класс, если можно то более развернутый ответ, !
Ответ:
GeintQQ
16.08.2020 17:25
#include "stdafx.h"#include <iostream>#include <windows.h>#include <ctime>using namespace std;int main(){ SetConsoleCP(1251); SetConsoleOutputCP(1251); srand(time(0)); int n,t; double ot=0, pol=0, nol=0; cout << "Введите размер массива " << endl; cin >> n; double *core = new double[n]; for (int i = 0; i < n; i++) { cout << "Введите элемент " << endl; cin >> core[i]; } for (int i = 0; i < n; i++) { if (core[i] < 0) { ot++; } if (core[i] > 0) { pol++; } if (core[i] == 0) { nol++; } } cout << "Положительных: " << pol << ", отрицательных: " << ot << ", нулей:" << nol << endl;}
0,0
(0 оценок)
Популярные вопросы: Информатика
Patara1986
06.02.2020 05:11
Сделать нужно с В то далёкое время, когда Паша ходил в школу, ему очень не нравилась формула Герона для вычисленияплощади треугольника, так как казалась слишком сложной. В...
Polina011020040
21.08.2020 08:30
6. написать программу тремя с циклами «до», «пока» и с параметром ). : ввести n чисел. найти сумму четных из них. проанализируйте решения. какое проще и почему?...
marinapizdec
10.12.2020 19:35
Одной из основных функций графического редактора является: 1)хранение кода изображения 2)создание изображения 3)просмотр и ввод содержимого видеопамяти 4)ввод изображения...
almaz2008
14.12.2022 05:51
задание по информатике. Дан алгоритм, записанный на алгоритмическом языке. Представьте его в виде блок-схемы....
Den4ik11tbbbb
31.10.2022 17:16
Информатика - это наука - это наука фонетика - это наука о ботаника - это раздел науки о земледельцы - это люди, животноводы - это люди, тяжёлая промышленность - это лёгкая...
torra11
20.12.2022 21:28
Нужно выберите те номера,под которыми наречия пишутся через дефис.в таблице найдите, какой букве соответствует номер.из полученных букв составьте слово. 1) (бок) (о) бок 2)(давным)...
777angel777likoy8mjs
17.07.2021 16:34
)1. У исполнителя Альфа две команды, которым присвоены номера:1. прибавить 12. умножь на b (b – неизвестное натуральное число; b≥2)Выполняя первую из них, Альфа увеличивает...
Anonimka04
02.04.2022 10:00
Семья потребляет за неделю 12 кг картофеля сколько картофеля в среднем потребляет семья за один день запишите ответ в виде смешанного числа ставлю 5...
Pechencka666
02.04.2022 10:00
Какой коэффициент трения между колёсами автомобиля и дорогой, если масса авто 4т и сила тяги 6,5кн?...
andreywwwoooandrey
02.04.2022 10:00
Почему монгольские ханы не давали разрешение на княжение нижегородским князьям?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?