В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Polina011020040
Polina011020040
21.08.2020 08:30 •  Информатика

6. написать программу тремя с циклами «до», «пока» и с параметром ). : ввести n чисел. найти сумму четных из них. проанализируйте решения. какое проще и почему?

Ответ:
jula1985ozpajo
jula1985ozpajo
16.06.2020 11:59

uses crt;

var s,n,ch:integer;

begin

for i:=1 to n do

begin

if ch mod 2 = 0 then

s:=s+ch;

end;

end.

 

uses crt;

var s,n,ch,i:integer;

begin i:=1;

while i <=n do

begin

if ch mod 2 = 0 then

s:=s+ch; inc(i);

end;

end.

 

 

uses crt;
var s,n,ch,i:integer;
begin i:=1;
n:=5;
repeat
begin
readln(ch);
if ch mod 2 = 0 then
s:=s+ch; inc(i);
end;
until i>=n;

writeln(s);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?