В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MELEKLER87
MELEKLER87
16.05.2021 07:21 •  Информатика

Написать программу на паскале которая печатает первую и последнюю цифру 4-х значного числа, сравнивает их и печатает какое из этих двух цифр больше

Ответ:
нвчббисмт
нвчббисмт
07.10.2020 20:01
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadInteger('Введите число').ToString();
var (d1,d4):=(a[1].ToDigit(),a[4].ToDigit());
writeln('первая: ',d1,'; четвертая: ',d4);
if d1>d4 then write ('больше ',d1) else if d1<d4 then write('больше ',d4) else
write('цифры равны: ',d1);
end.
0,0(0 оценок)
Ответ:
dkniga041
dkniga041
07.10.2020 20:01
Var
x:integer;
begin
Read(x);
Writeln(x div 1000, ' ', x mod 10);
if x div 1000 > x mod 10 then Writeln(x div 1000, ' - больше');
if x div 1000 < x mod 10 then Writeln(x mod 10, ' - больше');
if x div 1000 = x mod 10 then Writeln('Они равны');
end.

Пример:
1234
1 4
4 - больше
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?