В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MYSABIEKOVA57
MYSABIEKOVA57
04.09.2021 13:06 •  Информатика

На языке паскаль составить программу, которая в диапазоне найдёт все тройки натуральных а,в,с, подчиняющихся равенству a^2+в^2=с^2

Ответ:
risimonenko
risimonenko
04.10.2020 13:03
// PascalABC.NET 3.2, сборка 1344 от 22.11.2016
// Внимание! В других версиях работа не гарантируется!
begin
  for var a:=1 to 300 do
    for var b:=1 to 300 do
      for var c:=1 to 300 do
        if a*a+b*b=c*c Then Write(a,',',b,',',c,' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?