В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
katiaefimova
katiaefimova
26.03.2020 17:39 •  Информатика

Написать программу, которая выведет из n чисел числа кратные 3 и максимальное из них, если нет чисел кратных 3, вывести no

Ответ:
никита16l
никита16l
04.08.2020 08:57
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
write('Введите n: ');
var a:=ArrRandom(ReadInteger(),1,100);
write('сгенерированный массив: ');
a.Println();
var b:=a.Where(x->x mod 3=0);
if(b.Count()<>0) then
begin
write('числа кратные 3: ' );
b.Println();
write('максимальное из кратных 3: ',b.Max());
end else write('no');
end.
0,0(0 оценок)
Ответ:
timkaserka
timkaserka
04.08.2020 08:57
Var
n,tmp, i, max:integer;
fl:boolean;
begin
Read(n);
fl:=false;
max:= -1000*1000*1000-13;
for i:= 1 to n do
  begin
  Read(tmp);
  if (tmp mod 3 = 0) then
    begin
    fl:= true;
    if (max <tmp ) then
      max:= tmp;
    writeln(tmp, ' ');
    end;
  end;
  if (fl) then Writeln('Максимальное: ', max)
  else Writeln('NO');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?