Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
alievvusal57vusal
16.06.2021 02:22 •
Информатика
Паскаль. с клавиатуры вводится натуральное число x. требуется получить число y, в котором записаны цифры числа x в обратном порядке. например, x=123 y=321. примечание. решите с рекурсивной процедуры. 50
Ответ:
Walker95
07.10.2020 11:50
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
procedure Rvr(var n,nr:BigInteger);
begin
if n<>0 then begin
nr:=nr*10+ n mod 10;
n:=n div 10;
Rvr(n,nr)
end
end;
begin
var nr:=BigInteger(0);
var n:=ReadlnString('Введите натуральное число:').ToBigInteger;
Rvr(n,nr);
Writeln(nr)
end.
Пример
Введите натуральное число: 234536406567867348292735385468776123478182736
637281874321677864583537292843768765604635432
0,0
(0 оценок)
Ответ:
tatpolli8
07.10.2020 11:50
Var X, Y: longint;
procedure revX(X: longint; var Y: longint);
begin
if X <> 0 then
begin
Y := Y * 10 + (X mod 10);
revX(X div 10, Y);
end;
end;
begin
write('Введите X = ');
readln(X);
revX(X, Y);
writeln(Y);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
MelliLisska
19.05.2021 07:37
Составь программу парковка...
alena7571
17.05.2020 03:14
Какое количество информации содержит один разряд двоичного числа...
16вопрос
08.06.2023 06:54
Какие информационные носители вы используете в жизни?...
Бубух
11.11.2021 08:41
Сколько значащих нулей в двоичной записи числа 54?...
ЛадаПодмаркова
31.08.2021 19:35
Через adsl соединение файл размером 1000 кбайт передавался 32 с . сколько секунд потребуються для передачи файла размером 625 кбайт....
suchilinaelya
13.04.2021 08:46
Подскажите где скачать программу delpĥi бесплатно и без левых установок...
dolloc
09.07.2020 09:02
Html. создайте ссылки на закладки находящиеся в коде: пример в данном тексте находятся 4 закладки. создайте ссылки на них....
lerkakotik1983
09.07.2020 09:02
Какой длинны должен быть код чтобы алфавитом из 3 букв закодировать 200 символов...
dasha190800
10.08.2021 14:04
Напишите программу, которая вводит адрес файла и «разбирает» его на части, разделенные знаком / . каждую часть нужно вывести в отдельной строке. пример: введите адрес файла:...
ghenek2004
09.07.2020 09:02
Какие основные устройства находятся на системной плате...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
procedure Rvr(var n,nr:BigInteger);
begin
if n<>0 then begin
nr:=nr*10+ n mod 10;
n:=n div 10;
Rvr(n,nr)
end
end;
begin
var nr:=BigInteger(0);
var n:=ReadlnString('Введите натуральное число:').ToBigInteger;
Rvr(n,nr);
Writeln(nr)
end.
Пример
Введите натуральное число: 234536406567867348292735385468776123478182736
637281874321677864583537292843768765604635432
procedure revX(X: longint; var Y: longint);
begin
if X <> 0 then
begin
Y := Y * 10 + (X mod 10);
revX(X div 10, Y);
end;
end;
begin
write('Введите X = ');
readln(X);
revX(X, Y);
writeln(Y);
end.