В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составить программу,которая заполняет массив a(1..20) случайными числами [-2; 2]вычислить произведение отрицательных элементов массива с индексами от n до m включительно(n,m вводятся с клавиатуры)

Ответ:
натуся103
натуся103
07.10.2020 11:26
//PascalABC.NET версия 3.3.1590 от 03.12.2017
//Если программа не запускается, то обновите версию
begin
    var a := ArrRandomInteger(20, -2, 2);
    Writeln(a);
    var n := ReadInteger('n=');
    var m := ReadInteger('m=');
    a := a.Skip(n - 1).Take(m - n).ToArray();
    Writeln(a);
    if a.Any(x -> x < 0) then
        writeln(a.Where(x -> x < 0).Aggregate(1, (x, y)-> x * y));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?