В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Серафим6776
Серафим6776
24.03.2021 08:31 •  Информатика

Составьте программу, которая формирует массив из 20 случайных чисел от -10 до 10выводит на экрын элементы с нулевыми значениями и их индексами

Ответ:
AvdAda24
AvdAda24
07.10.2020 10:49
Const Sz = 100; // Размер массива

var
a: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i: integer;

begin
N := 20;
for i:=1 to N do
a[i] := Random(20)-10;
writeln('Элементы массива: ');
for i:=1 to N do
write (a[i],' ');
writeln;
for i:=1 to N do
begin
if (a[i]=0) then
writeln(a[i],' ',i);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?