В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Gusein123
Gusein123
21.03.2022 16:04 •  Информатика

Напишите программу, которая вводит четырёзначное число и определяет, верно ли, что в его десятичной записи цифры стоят в порядке возрастания

Ответ:
Galiavey370
Galiavey370
07.10.2020 10:32
Program n1;
var a,d1,d2,d3,d4: integer;
begin
readln(a);
d4:= a mod 10;
a:= a div 10;
d3:= a mod 10;
a:= a div 10;
d2:=a mod 10;
a:=a div 10;
d1:= a mod 10;
a:=a div 10;
if((d2>d1) and (d3>d2) and (d4>d3)) then write('в этом числе цифры стоят в порядке возрастания') else write('в этом числе цифры не стоят в порядке возрастания');
end.
0,0(0 оценок)
Ответ:
счастье101
счастье101
07.10.2020 10:32
Var s: string;
begin  write('число: ');  readln(s);
  if (s.Sorted.JoinIntoString(''))=s then writeln('Да')
  else writeln('Нет');
end.

число: 1357
Да

число: 3576
Нет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?