Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
тата279
17.05.2022 20:54 •
Информатика
Водномерном массиве, состоящем из n действительных элементов, вычислить: 1) произведение положительных элементов массива
Ответ:
ymniupisos
10.09.2020 06:41
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=SeqRandom(ReadInteger('n='),-99,99).Select(t->t/10).ToArray;
a.Println;
Writeln('П = ',a.Where(t->t>0).Aggregate(1.0,(x,y)->x*y))
end.
Пример
n= 15
-7.4 -0.9 -2.6 6.9 2.7 -7 7.8 3.6 7.6 -5.6 -1.4 8.4 -6.1 6.8 -3.1
П = 227097.1842048
0,0
(0 оценок)
Популярные вопросы: Информатика
Imdav88
05.07.2021 10:38
Какой вид примет содержащая абсолютную и относительную ссылку формула, записанная в ячейке C1, после ее копирования в ячейку C2?...
Валерия1804
10.05.2021 03:37
Написать программу, которая в промежутке чисел [2003, 100000] ищет числа, которые делятся на 3 и 5 и не делятся на 10. Вывести количество таких чисел и максимальное из низ....
nastunya22
21.03.2020 10:40
Какие сервисы представляется пользователям на портале www.edu.ru?...
Dryunya1989
17.05.2022 09:55
Увеличить все положительные элементы массива на 1 на паскале...
юлия19844
08.07.2020 19:42
Что произойдёт, если в текстовом редакторе набрать комбинацию клавиш shift + alt + d ?...
9854123g
29.08.2020 15:35
Вкинозале 32 рядов, в каждом ряду 16 мест. какое количество информации несет сообщение о том, что вам купили билет на 7 ряд 5 место?...
superakkroyale2
14.12.2022 05:08
Осталось около 1 часа! ! напишите программу поиска минимального числа, большего числа k, которое делится на d. входные данные: два целых числа: первое число k, второе число d (...
ValeriaBezzubik
28.04.2022 17:58
4^1014+2^1015-9 подскажите, , сколько единиц получится в двоичной записи этого выражения?...
svsand
28.07.2020 06:34
Минимальный целочисленный неотрицательный а...
asyazakharchenko3011
10.12.2021 06:05
Какие клавиши можно обычно вставлять текст, находящиеся в буфере обмена? а) shift+ ins б) shift+ del в) alt+ ctrl г) саps lock + enter д) scroll...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=SeqRandom(ReadInteger('n='),-99,99).Select(t->t/10).ToArray;
a.Println;
Writeln('П = ',a.Where(t->t>0).Aggregate(1.0,(x,y)->x*y))
end.
Пример
n= 15
-7.4 -0.9 -2.6 6.9 2.7 -7 7.8 3.6 7.6 -5.6 -1.4 8.4 -6.1 6.8 -3.1
П = 227097.1842048