Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
654850
18.10.2020 10:37 •
Информатика
1.сформировать и вывести в строчку целочисленный массив размера 20,содержащий 20 положительных чисел: 1,2, 2.вывести массив из 20 случайных чисел.найти произведение элементов. 3.дан массив размера 40.найти номер максимального элемента.
Ответ:
Alla950
21.08.2020 01:26
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!
№1
begin
var a:=ArrGen(20,i->i+1); a.Println;
end.
Пример
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
№2
begin
var a:=ArrRandom(20,-99,99); a.Println;
Writeln('П = ',a.Aggregate(BigInteger(1),(x,y)->x*y))
end.
Пример
92 6 39 -33 34 -22 -97 52 58 55 -42 -59 -15 -19 -91 76 -69 82 -19 -69
П = -309778851231495493804367495884800
№3
begin
var a:=ArrRandom(40,-99,99); a.Println;
Writeln('Номер максимального элемента = ',a.IndexMax+1)
end.
Пример
-30 85 -57 -5 -64 20 48 83 19 -32 -56 10 21 83 78 20 89 -5 71 -78 -59 88 -10 -94 -80 -58 24 37 -1 66 -71 -9 43 55 -14 -79 -33 -19 -34 68
Номер максимального элемента = 17
0,0
(0 оценок)
Популярные вопросы: Информатика
ladushiklevonik1
08.09.2022 12:53
Составьте программу вывода на экран столбиком четырех любых чисел. через паскаль...
дартячтчтт
08.01.2023 07:09
Здравствуйте с задачей по информатике: Определите суммы цифр первой половины и второй половины числа. Если цифр нечётное количество, среднюю цифру выкинуть. Вывести...
kokeoru1
31.07.2021 09:28
Составить блок-схему алгоритма и программу на Паскале для вычисления функций z. Ввести программу в Паскале, вычислить значения функции и проверить ее для самостоятельно...
savdyut
15.01.2023 05:54
Напишите программу для решения следующей задачи: Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями: F(n) = 1 при...
мика0955
25.10.2020 13:11
ответь на вопросы. Как настроить анимацию в PowerPoint.?Какие 4 вида анимационных эффекторов есть в программе PowerPoint? ...
Andreораидзпч
25.12.2021 12:06
Дайте определения: 1. Программа2. Программное обеспечение3.Системное ПО4.Прикладное ПО5.Система программирования-это..6.Операционная система7.Программное обеспечение...
ольга2224
29.09.2022 18:49
Если например у меня два диска и я устанавливаю вирус на один диск он затронит второй?...
salixova
10.09.2020 06:57
Робо-сумо. Урок 2 ДО 22:00 сделаю лучшим ответом >...
Мусора12233334555
24.03.2020 07:31
А как сделать моё домашнее задание...
лена1278
11.01.2020 21:30
1.Що потрібно зробити , щоб створити звіт зведеної таблиці? 2.Чи може виявитись помилковим розташування даних у зведеній таблиці? 3.Які з цих дій можна виконувати...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
№1
begin
var a:=ArrGen(20,i->i+1); a.Println;
end.
Пример
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
№2
begin
var a:=ArrRandom(20,-99,99); a.Println;
Writeln('П = ',a.Aggregate(BigInteger(1),(x,y)->x*y))
end.
Пример
92 6 39 -33 34 -22 -97 52 58 55 -42 -59 -15 -19 -91 76 -69 82 -19 -69
П = -309778851231495493804367495884800
№3
begin
var a:=ArrRandom(40,-99,99); a.Println;
Writeln('Номер максимального элемента = ',a.IndexMax+1)
end.
Пример
-30 85 -57 -5 -64 20 48 83 19 -32 -56 10 21 83 78 20 89 -5 71 -78 -59 88 -10 -94 -80 -58 24 37 -1 66 -71 -9 43 55 -14 -79 -33 -19 -34 68
Номер максимального элемента = 17