В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
annajeon58
annajeon58
04.05.2022 08:52 •  Информатика

Написать программу в с++ дано натуральное число. определить, сколько раз в нём встречается максимальная цифра.

Ответ:
golovko2006ovr6m1
golovko2006ovr6m1
07.10.2020 03:11
#include <iostream>
using namespace std;
int A[20];

int main()
{
int n, c, p, max;
int counter, ncounter;
counter = 0;
cin >> n;
c = n;
p = n;
for (c; c>0;)
{
 counter++;
  c = c / 10;
 A[counter] = p - c * 10;
 p = c;
 if (c > 0 && c < 10)
 {
  A[counter + 1] = c;
 }
}
max = 0;
ncounter = 0;
for (int s = 1; s <= counter; s++)
{
 if (A[s] > max)
 {
  max = A[s];
  ncounter = 0;
 }
 if (A[s] == max)
 {
  ncounter++;
 }
}
cout << ncounter;
system("pause");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?