В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ногл289
ногл289
23.07.2021 14:31 •  Информатика

Написать программу: на ферме 40 животных,козы,коровы и овцы. вывести экран все возможные комбинации,при условии что коров в два раза больше чем коз. нужно,это информатика)

Ответ:
школааксай
школааксай
07.10.2020 02:57
Var
  i, kor, koz, ov: integer;

begin
  for i := 1 to 40 do
  begin
    koz := i;
    kor := 2 * koz;
    ov := 40 - (koz + kor);
    if ov < 0 then break;
    writeln('Овец: ', ov, ' Коров: ', kor, ' Коз: ', koz);
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?