В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Alihan1600
Alihan1600
08.09.2021 00:05 •  Информатика

Решить эту . (написать программу на языке c++) . в некотором государстве в обращении применяются купюры достоинством 1, 5, 10, 50, 100, 500 и 1000 единиц. сколькими можно разменять купюру достоинством 1000 единиц? найти количество всех простых чисел в диапазоне от 2 до 100 000.

Ответ:
shmiganastya06
shmiganastya06
06.10.2020 23:50
"Найти количество всех простых чисел в диапазоне от 2 до 100 000", - решение через Решето Эратосфена.
#include <iostream>
#include <vector>
using namespace std; 
 
int main()
{
    unsigned a = 0, b = 0;
    cin >> a >> b;
    vector<char> v(b + 1, '1');
     for (unsigned i = 3; i < v.size(); i += 2) {
        for (unsigned j = i + i; j < v.size(); j += i) {
            vec[j] = '0';
        }
    }
 
    if (a == 2) {
        cout << 2 << " ";
    }
   
    a += !(a&1);

    for (unsigned i = a; i < v.size(); i+=2){
        if (vec[i] == '1') {
            cout << i << " ";
        }
    }
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?