В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MrDabilin
MrDabilin
12.02.2021 18:28 •  Информатика

Программа получает на вход количество чисел в последовательности, а затем сами числа. количество чисел не превышает 1000. введённые числа по модулью не превышают 30 000. программа должна вывести одно число: сумму чисел, кратных 7 и оканчивающихся на 4.

Ответ:
професор3814
професор3814
06.10.2020 23:42
//PascalABC.NET
var
    s : integer;
begin
    var n := ReadlnInteger('Сколько будет чисел? ');
    writeln('Вводите числа');
    var a := ReadArrInteger(n);
    for var i:=0 to n-1 do
        if (a[i] mod 10 = 4) and
            (a[i] mod 7 = 0) then
            s := s + a[i];
    writeln('Сумма чисел равна ', s)
end.

Программа получает на вход количество чисел в последовательности, а затем сами числа. количество чис
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?