В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
szelenkooz1uqs
szelenkooz1uqs
22.03.2020 16:39 •  Информатика

Написать программу в с++, определяющую, какое число чаще других встречается в последовательности целых случайных чисел. для генерации чисел использовать линейный конгруэнтный метод.

Ответ:
kadieva1976
kadieva1976
06.10.2020 20:38
#include <iostream>
using namespace std;
const int n = 15;

double congruential(int &x) // функция генерации псевдослучайных чисел
{
 const int m = 100, // генерация псевдослучайных чисел в диапазоне
значений от 0 до 100 (выбирается случайно m > 0)
           a = 8, // множитель (выбирается случайно 0 <= a <= m)
         inc = 65; // инкрементирующее значение (выбирается случайно 0
<= inc <= m)
 x = ((a * x) + inc) % m; // формула линейного конгруэнтного метода
генерации псевдослучайных чисел 
 return (x / double(m));
}

int main()
{
    double arr[n];
    double num, frq, max_frq;
    int x0 = 20;
    for (int i=0; i<n; i++) {
        arr[i] = congruential(x0);
        cout << arr[i] << " ";
    }

    num = arr[0];
    max_frq = 1;
    for (int i=0; i < n-1; i++) {
        frq = 1;
        for (int k = i+1; k<n; k++) 
            if (arr[i] == arr[k])
               frq += 1;
        if (frq > max_frq) {
            max_frq = frq;
            num = arr[i];
        }
    }
    cout << endl;   
if (max_frq > 1) 
        cout << max_frq << " : " << num << endl;
else
        cout << "All uniqum" << endl;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?