Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
pelmen123456789
20.08.2022 22:02 •
Информатика
Сблок схемы или паскаля. составь те алгоритм для решения следуюшей залачи. среди n произвольных вещественных чисел. найдите количество неравных нулю.
Ответ:
mhey3303
01.09.2020 06:57
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrReal('Вводите:',ReadInteger('n='));
Writeln('Количество нулевых равно ',a.Where(x->x=0).Count)
end.
Пример
n= 8
Вводите: 3 1.5 -2.4 0 8 0 0.2 1
Количество нулевых равно 2
0,0
(0 оценок)
Ответ:
ARCrafter
01.09.2020 06:57
Var n,i,k:integer;
a:array [1..50] of real;
begin
write('Введите целое N = '); readln(n);
for i:=1 to n do
begin
write('a[',i,'] = '); readln(a[i])
end;
k:=0;
for i:=1 to n do
if a[i]<>0 then k:=k+1;
writeln('k = ',k)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
strukserzh
28.02.2021 12:06
3D моделдеуги D нени билдиреди...
ALEXFORBIDDEN
14.01.2022 12:55
Какое количество данных может находиться в данном массивеvar ch: array[6..18] of integer;?Варианты ответов6121813...
olivcad
02.06.2023 04:00
Написать программу нахождения суммы чисел от А до В (A...
Крутойбрат
23.05.2023 19:36
Попробуйте сформулировать содержание оптимального планирования для своей учебной деятельности....
KrASaVa307
17.02.2022 03:37
Картинка: https://i.imgur.com/jPRU6Cz.jpg...
кристина1814
17.02.2022 03:37
Во Установите верный порядок следования команд при поиске вмассиве из 50 элементов, количество элементов равных k.Варианты ответов. i:=0;for i:=1 to n doif a[i]=k then. i:=i+1;...
N1ke1N1kev1ch
04.07.2022 16:14
Укажите действия пользователя при котором начнётся выполнение скрипта...
Блейк51
14.05.2023 04:27
Айсұлу «Менің сүйікті қалам» тақырыбында мәтіндік процессорда жоба жасады. Айсұлуға бет параметрлерін орнатуға сіздің көмегіңіз керек. Сөйлемді аяқтаңыз А. Бетті кітап түрінде...
привет897
14.05.2023 04:27
Что производит следующий фрагмент программы?For i:=1 to 8 do writeln (a[i]);Варианты ответовВвод элементов массива по формуле• Ввод элементов массива с клавиатуры• Вывод элементов...
Rayanna1
27.04.2020 12:03
Нарисуйте 3D модель этогл треугольника...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrReal('Вводите:',ReadInteger('n='));
Writeln('Количество нулевых равно ',a.Where(x->x=0).Count)
end.
Пример
n= 8
Вводите: 3 1.5 -2.4 0 8 0 0.2 1
Количество нулевых равно 2
a:array [1..50] of real;
begin
write('Введите целое N = '); readln(n);
for i:=1 to n do
begin
write('a[',i,'] = '); readln(a[i])
end;
k:=0;
for i:=1 to n do
if a[i]<>0 then k:=k+1;
writeln('k = ',k)
end.