В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
rosharh88
rosharh88
03.01.2023 12:29 •  Информатика

Синформатикой! нужно написать программу в паскаль abc "линейные алгоритмы. решение " 1.мальчик может бегать в 3 раза быстрее, чем ходить. скорость его ходьбы составляет а км/час. мальчик принял участие в марафонском забеге, но сошел с дистанции, пробежав х км. сколько времени он затратил? 2. цех по ремонту бытовой техники имеет ежедневно прибыль р, с которой платит налог 70%. из оставшейся доли прибыли 30% идет на развитие производства, а остальное - на заработную плату 8 работникам. какова заработная плата работника за месяц?

Ответ:
VovaUtyuzh
VovaUtyuzh
06.10.2020 09:02
1) program znanija2;
var speed, A, X:integer;
    time:real;
begin
  readln(A);
  readln(X);
  speed:= A * 3;
  time:= X / speed;
  writeln(time);
end.

2)

program znanija3;
var P:integer;
    tax, rest, wages, answer:real;
begin
  read(P);
  tax:=(P*70)/100;
  rest:= P - tax;
  wages:= (rest*70)/100;
  answer:= wages / 8;
  writeln(answer);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?