Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Neal12
04.02.2021 01:38 •
Информатика
Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).сделайте три варианта программы,используя операторы while,repeat ,for.
Ответ:
popopolka111
06.10.2020 08:12
Program;
var a,i,sr,k,sum:integer;
k:=0;
sum:=0;
Begin
for i:=1 to 10 do
begin;
read(a);
k:=k+1;
sum:=sum+a;
sr:=sum/k;
end;
write(sr);
End.
Program;
var a,i,k,sum,sr,r:integer;
Begin
k:=0
sum:=0;
r:=0;
repeat
begin;
read(a);
k:=k+1;
sum:=sum+1;
r:=r+1;
until r=10;
sr:=sum/k;
write(sr);
End.
Цикл While подумай сама,уверен у тебя получится
0,0
(0 оценок)
Популярные вопросы: Информатика
ПитерДина
28.01.2022 23:30
Переведите число из двоичной системы в восьмиричную и шестнадцатиричную, а затем проверьте результаты, выполнив обратный перевод: 10011010(2)...
мротмсс
30.09.2022 15:04
Решите ! 1) объем сообщения – 7,5 кбайт. известно, что данное сообщение содержит 7680 символов. какова мощность алфавита? 2) объем сообщения, содержащего 2048 символов, составил...
Глеб0071
12.09.2022 13:23
Имеется статический метод void M(), вызов которого может выбрасывать исключения Exception и ArgumentException. Объявить статический метод int M1(), который вызывает метод М()...
n254n
01.01.2020 11:19
Өнім кестесі үшін кілттік өрісті анықтаңыз очень нужно...
АннаЛео147
19.03.2021 02:05
От какого глаголы нельзя образовать форму будущего времени 1-го лица единственного числа? положить, сжечь, победить, висеть, убедить, пылесосить, возвратить участвовать, подрастать,...
vika23562
19.03.2021 02:05
Почему в тепловых что называют кпд теплового двигателя?...
yuliaprok61yulia1206
19.03.2021 02:05
Сочинение на тему что такое справедливость...
PicaChuShiK
19.03.2021 02:05
Сочинение на рассказ маму 9 предложений...
styopyshca
19.03.2021 02:05
4класс. решите уравнения. а) 2*х - 267= 133 б) 287+(120-х) = 300 в) 300-78/х = 287 г) 750+10*х = 750...
AAOO
19.03.2021 02:05
Пётр1 - созидатель - разрушитель. описать какой он созидатель и разрушитель....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,i,sr,k,sum:integer;
k:=0;
sum:=0;
Begin
for i:=1 to 10 do
begin;
read(a);
k:=k+1;
sum:=sum+a;
sr:=sum/k;
end;
write(sr);
End.
Program;
var a,i,k,sum,sr,r:integer;
Begin
k:=0
sum:=0;
r:=0;
repeat
begin;
read(a);
k:=k+1;
sum:=sum+1;
r:=r+1;
until r=10;
sr:=sum/k;
write(sr);
End.
Цикл While подумай сама,уверен у тебя получится