В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
jddosnfkdmsns
jddosnfkdmsns
24.11.2020 08:02 •  Информатика

Напишите программу на языке pascal дано: натуральное число -n выяснить с цикла repeat является ли оно простым (то есть делится на 1 и на само себя)

Ответ:
MaxonA
MaxonA
06.10.2020 08:01
Var
  i, n: integer;
 
begin
  i := 1;
  read(n);
  repeat
    i := i + 1;
    if(n mod i = 0) and (n <> i) or (n = 1) then
      begin
       write('Число ', n, ' не является простым');
       exit;
      end;
  until i = trunc(sqrt(n)) + 1;
  write('Число ', n, ' является простым');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?