В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир

По м о г и т е, п о ж а л у й с т ! 1) вводится массив, состоящий из целых чисел. найти наибольшее среди них. входные данные сначала задано число n — количество элементов в массиве (1n35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести значение наибольшего элемента в массиве. примеры входные данные 3 1 2 3 выходные данные 3 2) напишите программу, которая циклически сдвигает элементы массива вправо (например, если элементы нумеруются, начиная с нуля, то 0-й элемент становится 1-м, 1-й становится 2-м, последний становится 0-м, то есть массив {3, 5, 7, 9} превращается в массив {9, 3, 5, 7}). входные данные сначала задано число n — количество элементов в массиве (1n35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести массив, полученный после сдвига элементов. примеры входные данные 6 4 5 3 4 2 3 выходные данные 3 4 5 3 4 2

Ответ:
Dania2432
Dania2432
26.04.2020 14:16
var a: array [1..100] of integer; i,  n ,  max : integer; begin writeln('rozmer'); readln(n); randomize ; if (( n>=1) and (n<=35)) then for i:=1 to n do begin a[i]:=random(90)-45 ; write(a[i]:3); end; writeln; max:=a[1] ; for i:=2 to 100 do begin if a[i]>max then max:=a[i] ; end; writeln(max); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?