В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
анора10
анора10
01.04.2022 13:26 •  Информатика

Составьте программу в паскаль. седьмому классу на практике получено сдуть 1000 одуванчиков. бригада мальчиков первый день сдуло а одуванчиков, а бригада девочек в два раза меньше. в каждый последующий день производительность мальчиков уменьшалась на 10 %,а девочек росла на 15 % по сравнению с предыдущим. через сколько дней классы выполнит норму вопросительный знак сколько сделают бригада мальчиков и девочек в отдельности?

Ответ:
bombila663
bombila663
21.09.2020 13:15
Хорошая задачка! Хочется её решать в целых числах, но в условии этого не требуется.
var a,k:integer; m,d,sm,sd:real;
begin
write('A='); readln(a);
m:=a; d:=a/2;
sm:=m; sd:=d;
 k:=1;
while sm+sd<1000 do
 begin
 m:=m*0.9; sm:=sm+m;
 d:=d*1.15;sd:=sd+d;
 k:=k+1;
 end;
writeln('k=',k,'  sm=',sm:6:2,'  sd=',sd:6:2);
end.

Пример:
A=70
k=9  sm=428.81  sd=587.50
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?