В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kazbekkaharman
kazbekkaharman
03.03.2023 11:06 •  Информатика

Pascal ! дана последовательность натуральных чисел, завершающаяся число 0. определите наибольшую длину монотонного фрагмента последовательности (то есть такого фрагмента, где все элементы либо больше предыдущего, либо меньше). числа, следующие за числом 0, считывать не нужно.

Ответ:
zadoroznaa2001
zadoroznaa2001
06.10.2020 05:42
Var A,B,k,Max:byte;
Begin
Max:=1;
Read(A);
B:=A;
Repeat
if A>B then
   Begin
   if k>Max then Max:=k;
   k:=1;
   While (A>B)and(A>0) do
      Begin
      k:=k+1;
      B:=A;
      Read(A);
      End;
   End;
if A<B then
   Begin
   if k>Max then Max:=k;
   k:=1;
   While (A<B)and(A>0) do
      Begin
      k:=k+1;
      B:=A;
      Read(A);
      End;
   End;
if A=B then
   Begin
   if k>Max then Max:=k;
   k:=1;
   B:=A;
   Read(A);
   End;
Until A=0;
if k>Max then Write(k)
else Write(Max)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?