В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Даник2254
Даник2254
21.04.2022 05:22 •  Информатика

Сделать на паскале Напишите программу, которая заменяет в символьной строке все буквы «а» на буквы «б» с цикла «пока» (while):
2) 11. Запишите какое значение будет иметь переменная s после вы-полнения фрагмента программы
s:= '123456789'
вставить('ABC', s, 3) s:= '123456789';
Insert('ABC', s, 3);

Ответ:
Sashalizer
Sashalizer
06.03.2021 11:28

1)

var

 S : String;

begin

 readln(s);

while (Pos('а', S) > 0) or (Pos('a', S) > 0) do

   begin

     if Pos('а', S) > 0 then

       S[Pos('а',S)] := 'б'

         else

           S[Pos('a', S)]:= 'b';

   end;

writeln(S);

end.

2)

12ABC3456789

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?