В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Напишите программу, которая в последовательности целых чисел определяет среднее арифметическое положительных чисел , кратных 8. программа получает на вход целые числа, среди них есть хотя бы одно положительное число, кратное 8, количество введёных чисел неизвестно, последовательность числом заканчивается числом 0 (0 - признак окончания ввода , не входит в последовательность). программа должна вывести одно число: среднее арифметическое положительных чисел кратных 8. входные данные 10 16 8 14 0 выходные данные 12 составить программу

Ответ:
Traken
Traken
06.10.2020 01:21
#include <iostream>

using namespace std;

int main() {
 int a = -1, s = 0, c = 0;
 while(a != 0) {
   cin >> a;
   if( a > 0 && !(a%8)) {
      s+=a;
      c++;
    }
 }
 cout << (double)s/c << endl;
}   
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?