В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
damirnikiforov
damirnikiforov
12.10.2021 01:16 •  Информатика

Впаскале нужно написать программу: дан двумерный массив случайных чисел от -05 до 14 из 5 строк и 5 столбцов.вывести на экран первоначальные значения элементов массива в виде матрицы. поменять местами первый и второй столбец.вывести на экран новые значения элементов массива в виде матрицы кто знает,, с меня презент)

Ответ:
rtydykov
rtydykov
14.08.2020 21:45
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(5,5,-5,14);
  a.Println(4); Writeln(4*a.ColCount*'-');
  a.SwapCols(0,1);
  Writeln('*** Результирующий массив ***');
  a.Println(4);
end.

Пример
*** Исходный массив ***
  12  10   7  -2   5
  14   0   7   1  14
   0  -1   7   5   7
  -5  -5  -4  -4   9
   7   8  -5  12  12

*** Результирующий массив ***
  10  12   7  -2   5
   0  14   7   1  14
  -1   0   7   5   7
  -5  -5  -4  -4   9
   8   7  -5  12  12
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?