В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
joom3
joom3
25.01.2020 08:06 •  Информатика

Две целочисленный массив из 30 элементов . элементы массива могут принимать целые значения о 0 до 100 - учащихся выпускного класса за итоговый тестер информатике .составьте программу которая позволяет найти и вывести количество учащихся чья оценка за тест выше средней оценки в классе ))

Ответ:
hickov2003
hickov2003
05.10.2020 20:53
Program n1;
const n=30;
var a: array[1..n] of integer;
i,k,sum: integer;
sr: real;
begin
randomize;
sum:=0;
k:=0;
for i:=1 to n do
begin
a[i]:=random(101);
write(a[i],' ');
sum:=sum+a[i];
end;
sr:=sum/n;
writeln;
for i:=1 to n do if a[i]>sr then k:=k+1;
writeln(k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?