В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vera186
vera186
24.01.2023 15:21 •  Информатика

1-2. Напишите программу, в которой осуществляется ввод любых целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчëт суммы и среднего арифметического всех введённых чисел. Сначала запишите эту программу с оператором repeat, а затем с оператором while:

while <условие>do

begin

<серия команд

end:

while <yсловие>do

begin

серия команд>

end;

3. Напишите программу, в которой осуществляется ввод любых целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и вычисление суммы всех чётных чисел из ведённых. Запишите эту программу с оператором repeat или с оператором

while (условие: n mod 2=0).


1-2. Напишите программу, в которой осуществляется ввод любых целых чисел (ввод осуществляется до тех

Ответ:
irunadp0a62f
irunadp0a62f
08.02.2022 04:20

Программа:

Pascal:

№1)

var sum, j, k: integer;

begin

 readln(j);

 while j <> 0 do begin

   inc(k);  // k - кол-во введённых чисел

   sum := sum + j;  // сумма введённых чисел

   readln(j);

 end;

 writeln(sum/k);

end.

№2)

var sum, j, k: integer;

begin

 readln(j);

 repeat

   inc(k);  // k - кол-во введённых чисел

   sum := sum + j;  // сумма введённых чисел

   readln(j);

 until j = 0;

 writeln(sum/k);

end.

№3)

3.1) var sum, j: integer;

begin

 readln(j);

 repeat

   if j mod 2 = 0 then sum += j;

   readln(j);

 until j = 0;

 writeln(sum);

end.

3.2) var sum, j: integer;

begin

 readln(j);

 while j <> 0 do begin

   if j mod 2 = 0 then sum += j;

   readln(j);

 end;

 writeln(sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?