Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
хелпмиплиз666
22.07.2021 11:04 •
Информатика
Напишите программу, выводящую степень числа 2 от 1 до n (с цикла с предусловием while)
Ответ:
Polina2050
05.10.2020 18:55
Var
s: biginteger;
i, n: int64;
begin
s := 1;
i := 1;
read(n);
while i <= n do
begin
s := s * 2;
i := i + 1;
write(s,' ');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Sausage2281
04.10.2022 01:09
Никита написал программу в arduino ide для мигания светодиодом. скриншот программы представлен на рисунке. при компиляции программы никита получил несколько сообщений об ошибках...
тима156
05.05.2020 02:08
Запишите на языке паскаль логическое выражение, имеющее значение true при выполнении указанного условия и false в противном случае. результат вычисления выражения присвойте логической...
Idgy
16.05.2021 21:19
Реферат учащегося по информатике имеет объём 30 кбайт. каждая страница реферата содержит 42 строки по 76 символов в строчке, с алфавита - 256. сколько страниц в реферате? люди...
Qudipue1
16.05.2020 07:28
Для передачи секретного сообщения используется код, состоящий из заглавных латинских букв и цифр (всего используется 36 различных символов). при этом все символы кодируются одним...
лоллрр
01.02.2020 17:45
Написать программу печатающую все целые числа от а до b введенных с клавиатуры (repeat)...
3456789012345678905
17.03.2023 10:35
Вpascal abc написать мир (11 класс) мне нужен обычный текст с выводом моего имени на экран....
vitalik6300
17.05.2020 00:54
Вмарафоне участвуют 24 атлета. спец. устройство регистрирует прохождение финиша.,записывая его номер с мин. кол-вом бит.каков объем информ. сообщения если зарегистрировано 50% лайк...
Камилла1004
12.02.2022 05:05
Вмассиве b(n) заменить каждый элемент массива максимальным элементом массива ....
Анжела921
02.11.2020 09:25
Расположить числа, представленные в двоичной системе счисления, в порядке возрастания: 1001; 111; 100001; 010; 1101; 100; 110000; 10001. , !...
kotovich9292
26.03.2020 12:56
Дан двумерный массив. определить есть ли в данном массиве отрицательный элемент...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
s: biginteger;
i, n: int64;
begin
s := 1;
i := 1;
read(n);
while i <= n do
begin
s := s * 2;
i := i + 1;
write(s,' ');
end;
end.