В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DaniilFPS
DaniilFPS
08.03.2020 14:17 •  Информатика

Дан массив из 25 целых чисел. элементы массива могут принимать целочисленные значения от -200 до 200. определите количество нулевых элементов, индексы которых не кратны 3.

Ответ:
Artishokq
Artishokq
05.10.2020 18:36
Const
   N = 25;
Var
   A:array[1..N] of integer;
   i,k:integer;
Begin
k:=0;
Write('Исходный массив: ');
For i:= 1 to N do
    Begin
    A[i]:=random(401)-200;
    Write(A[i],' ');
    if (A[i] = 0)and(i mod 3 <> 0) then k:=k+1;
    End;
WriteLn;
WriteLn('k = ',k);
End.
0,0(0 оценок)
Ответ:
Face200
Face200
05.10.2020 18:36
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(25,-200,200); a.Println;
  Writeln('n=',a.Where((x,i)->(x=0) and ((i+1) mod 3<>0)).Count)
end.

Пример
13 -80 95 -146 127 -123 15 -98 51 119 -120 77 0 -9 85 165 -86 13 -37 157 -19 192 -80 156 178
n=1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?