В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Elkhadi54Skorpion
Elkhadi54Skorpion
22.02.2023 22:20 •  Информатика

Кто может написать программу, ну или хотя бы просто объяснить суть как ее сделать, заранее ! задана матрица с(5,5). получить вектор в, каждый элемент которого равен количеству нулей, состоящих в столбце матрицы. в с#.

Ответ:
дамчок
дамчок
02.08.2020 22:05
Using System;

class Program
{
    static void Main()
    {
        var random = new Random(DateTime.Now.Millisecond);
        int n = 5;
        int k;
        var c = new int[n, n];
        var b = new int[n];
        
        Console.WriteLine("C:");
        for (var i = 0; i < n; i++)
        {
            for (var j = 0; j < n; j++)
            {
                c[i, j] = random.Next(0, 9);
                Console.Write(c[i, j] + " ");
            }
            Console.WriteLine();
        }
        Console.WriteLine();
        for(int j = 0; j < n; j++) {
        k = 0;
        for(int i = 0; i < n; i++)
          if (c[i, j]==0) k++;
        b[j] = k;
        }
        Console.WriteLine("B:");
        for(int i = 0; i < n; i++)
            Console.Write(b[i] + " ");
        Console.WriteLine();
        Console.ReadKey();
    }
}

Пример:
C:
3 5 1 3 0
1 6 4 1 7
5 2 5 1 2
4 6 3 0 3
2 3 8 0 7
 
B:
0 0 0 2 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?