В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Verra990
Verra990
27.01.2020 19:01 •  Информатика

Составить программу вычисления количества трёхзначных чисел которые не кратны 5 с while

Ответ:
Faop
Faop
02.10.2020 23:06
Var i,k:integer;
begin;
i:=100;
while i<>1000 do
begin;
if i mod 5<>0 then k:=k+1;
inc(i);
end;
writeln(k);
end.
0,0(0 оценок)
Ответ:
sonyapanferova
sonyapanferova
02.10.2020 23:06
   Заметим, что всего имеется 900 трехзначных чисел - от 100 до 999.
   Если посчитать, сколько среди них чисел, кратных пяти, то вычтя его из 900, получим искомый ответ.
   Первое число, кратное 5, это 100. А все остальные получаются путем последовательного прибавления числа 5.

// PascalABC.Net 3.0, сборка 1064
var
  i,n:integer;
begin
  n:=0; i:=100;
  while i<1000 do begin Inc(n); i:=i+5 end;
  Writeln('Количество чисел равно ',900-n)
end.

Результат выполнения программы:
Количество чисел равно 720
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?