В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Andrei2111111
Andrei2111111
21.05.2022 01:10 •  Информатика

Написать программу в формате "паскаль", которая генерируется случайное трехзначное число и подсчитает количество цифр в нем равных 4 и 5. ! , !

Ответ:
igor99kz
igor99kz
05.10.2020 14:52
// PascalABC.NET 3.2, сборка 1387 от 17.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  randomize;
  var s:=Random(100,999).ToString;
  Writeln('Исходное число ',s);
  var k4:=0;
  var k5:=0;
  for var i:=1 to s.Length do
  case s[i] of
  '4':k4+=1;
  '5':k5+=1
  end;
  Writeln('Четверок в числе- ',k4,', пятерок- ',k5)
end.

Пример
Исходное число 954
Четверок в числе- 1, пятерок- 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?