В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
y6yyy
y6yyy
28.02.2022 07:23 •  Информатика

Pascal. составьте программу для определения принадлежности точки p с координатами (x, y) области, которая образована первой дугой синусоиды и осью ох.

Ответ:
viparistocrate
viparistocrate
05.10.2020 11:56
Если первая дуга синусоиды - синусоида при 0 <= x <= pi, то область изображена на рисунке.
Точка с координатами (x, y) принадлежит области, если 0 <= x <= pi и 0 < y < sin(x), лежит на границе, если первое выполнено, и y = 0 или y = sin(x), а иначе не лежит в области.

Код (PascalABC.NET 3.2):
begin
  var x, y: real;
  readln(x, y);
  if (0 <= x) and (x <= pi) then
    if (0 < y) and (y < sin(x)) then
      writeln('Внутри области')
    else if (0 = y) or (y = sin(x)) then
      writeln('На границе')
    else
      writeln('Не принадлежит')
  else
    writeln('Не принадлежит')
end.

Pascal. составьте программу для определения принадлежности точки p с координатами (x, y) области, ко
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?