В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vani2006
vani2006
11.04.2021 11:05 •  Информатика

Составить программу, которая подсчитывает количество четных чисел,количество нечетных чисел, сумму и среднее арифметическое в последовательности которая закачивает 0

Ответ:
адильхан9
адильхан9
05.10.2020 10:33
Program n1;
var a,kch,knc,k,sum: integer;
begin
write('введите 1 член последовательности: ');
readln(a);
knc:=0;
sum:=0;
kch:=0;
k:=0;
while a<>0 do begin
k:=k+1;
if a mod 2=0 then kch:=kch+1 else
knc:=knc+1;
sum:=sum+a;
write('введите следущий член: ');
readln(a);
end;
writeln('сумма: ',sum);
writeln('кол-во четных: ',kch);
writeln('кол-во нечетных: ',knc);
writeln('ср. арифмитическое: ',sum/k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?