Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
nastyalobzova1
28.08.2022 11:05 •
Информатика
Составьте программу которая в массиве a из 20 произвольных чисел находит произведение минимального элемента и среднего арифметического элементов данного массива
Ответ:
Алёна0Чан
14.08.2020 17:18
Лови)
const
k = 20;
var
A: array [1..k] of real;
i: integer;
min, average: real;
begin
writeln('Enter x:');
for i := 1 to k do
begin
A[i] := random(k);
writeln('A[', i, '] = ', A[i]);
end;
min := A[i];
average := 0;
for i := 1 to k do
begin
average := average + A[i] / k;
if min > A[i] then
min := A[i];
end;
writeln(min * average);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nata1116
15.02.2022 02:18
Примеры пустого множества и множества состоящего из 10 элементов...
andrejisaev20Andrey
29.10.2020 13:54
Дайте несколько возможных общих имён каждой группе а) буратино, мальвина,пьеро,артемон. б) 12 месяцев , морозко , золушка , синяя борода . в) москва, санк-петербург,...
sabekgnivslenti
22.07.2021 09:02
Примеры информационных сообщений,которые несут 1 бит информации...
sofiiishtepa
22.07.2021 09:02
Переведите число 1025 в двоичной системе...
Ирма69
22.07.2021 09:02
Шифр виженера. используя в качестве ключевого слово вагон,закодируйте слова: алгоритм,правила,информация...
mariyburova2001
22.07.2021 09:02
Синформатикой. 1)написать программу на turbo paskal, которая определяет все ли цифры трехзначного числа одинаковые...
anisimovaanech
31.05.2020 15:57
Написать словесный алгоритм про Винни-Пуха который ест мёд...
ekaterinabajewa
22.09.2022 09:03
Составь пищевую цепь из предложенных ниже организмов:...
ArseniiB1
22.09.2022 09:03
4 класс. Лит.Чт. с.160-166 - составить и записать небольшой рассказ от лица главного героя...
fhdjfjfuf
22.09.2022 09:03
Выпишите только подчинительные словосочетания. Укажите в них вид подчинительной связи. 1) Вся жизнь 2) Беседы учителей 3) Океан подхватывает 4) Постоянно думаем...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const
k = 20;
var
A: array [1..k] of real;
i: integer;
min, average: real;
begin
writeln('Enter x:');
for i := 1 to k do
begin
A[i] := random(k);
writeln('A[', i, '] = ', A[i]);
end;
min := A[i];
average := 0;
for i := 1 to k do
begin
average := average + A[i] / k;
if min > A[i] then
min := A[i];
end;
writeln(min * average);
end.