Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
smaile2
04.02.2023 13:12 •
Информатика
Составьте программу в паскале: вычислить сумм всех нечётных чисел в интервале от 1 до 2к-1. заранее огромное
Ответ:
никт11
26.08.2020 07:08
// PascalABC.NET 3.2, сборка 1377 от 19.01.2017
// Внимание! Если программа не работает, обновите версию!
begin
var k:=ReadInteger('k=');
Writeln('s=',Range(1,2*k-1,2).Sum)
end.
Пример
k= 4
s=16
0,0
(0 оценок)
Ответ:
halilappazov
26.08.2020 07:08
Var
k: integer; s: real;
begin
readln(k);
s := ((1+(2*k-1))/2)*(((2*k-1)-1)/2+1);
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
werttyu890
26.11.2020 23:06
с задачкой.В русском языке буква М встречается с вероятностью 0,025, а буква Y - с вероятностью 0,02. Определите количество информации в слове МУМУ ....
Pizetiv4ik
24.10.2021 13:46
Не написать программу phyton. Даны две строки экземпляр и подкласса . Разработайте программу объединения этих строк, преобразования первой строки в список и исключения из второй...
Just0a0reader
05.10.2022 06:18
В чем разница между простыми и статическими методами в с# (си шарп)...
shram070
16.09.2022 08:04
Как завершить процесс? Close() не процесс остается висеть.Windows FormsС++...
Алшиния
20.12.2022 00:19
Вот такая фигня появляется на компьютере, что надо сделать? ...
Madi12kz
17.08.2020 06:08
Придумать ситуацию на использование ветвления; составить алгоритм и построить блок-схему....
666642
14.08.2022 19:57
Действие, при котором данные из процессора поступают на периферийное устройство или обратно относится к категории процессор-память процессор -увв обработка данных...
пукимэн228
14.08.2022 19:57
Написать программу функции y=(a^2-2b-c^2)/3ab при значениях a=20 b=10 c=14...
karina27042005
17.11.2022 07:14
Требуется определить является ли данный год високосным.(напомним, что год является високосным , если его номер кратен 4, но не кратен 100, а также если он кратен 400.) c++ не...
kryakrya04
28.07.2020 03:45
Каков результат выполнения ниже алгоритма для чисел 8 и 5? начало прибавить 23 прибавь 35 вычти 27 если полученное число больше 10 то прибавь 5 если полученное число четное то...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var k:=ReadInteger('k=');
Writeln('s=',Range(1,2*k-1,2).Sum)
end.
Пример
k= 4
s=16
k: integer; s: real;
begin
readln(k);
s := ((1+(2*k-1))/2)*(((2*k-1)-1)/2+1);
writeln(s);
end.