В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dariyaomelchen
dariyaomelchen
24.06.2021 06:56 •  Информатика

Задан массив а[1..5]. составьте программу, которая выводит на экран элементы массива в обратном порядке.

Ответ:
dcherbaev7771
dcherbaev7771
05.10.2020 04:58
Const n=5; 
var a:array[1..n] of integer;
i:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51);
 write(a[i]:4);
 end;
writeln;
writeln('Массив A в обратном порядке:');
for i:=n downto 1 do write(a[i]:4);
writeln;
end.

Пример:
Массив A:
 37 39 41 9 25
Массив A в обратном порядке:
 25 9 41 39 37
0,0(0 оценок)
Ответ:
школьник812
школьник812
05.10.2020 04:58
// PascalABC.NET 3.2, сборка 1370 от 24.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(5,-99,99); a.Println;
  a.Reverse.Println;
end.

Пример
-80 64 42 -50 16
16 -50 42 64 -80
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?