В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
balasanyansilva
balasanyansilva
06.04.2023 22:21 •  Информатика

Написать программу на языке паскаль. напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. программа получает на вход количество чисел в последовательности, а затем сами числа. кто правильно напишет поставлю лучшее !

Ответ:
kabekesov99
kabekesov99
05.10.2020 02:34
Var n,a,i,k:integer;
begin
write('n = ');
readln(n);
k:=0;
writeln('Вводите числа:');
for i:=1 to n do
 begin
 readln(a);
 if a mod 4 = 0 then k:=k+1;
 end;
writeln('k = ',k);
end.

Пример:
n = 5
Вводите числа:
15
24
73
48
94
k = 2
0,0(0 оценок)
Ответ:
konuj
konuj
05.10.2020 02:34
Var a: array [1..100] of integer;

chis,i: integer;

begin

readln(chis);

for i:=1 to chis do readln(a[i]);

write('Числа кратные 4:');

for i:=1 to chis do if (a[i] mod 4 = 0) then write(a[i], ' ');

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?