В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
филосов00
филосов00
27.03.2020 22:36 •  Информатика

Напишите программу : винипух съедает 100 грамм варенья в первый день, во второй день ещё 100 грамм, в третий день 200 грамм, в каждый последующий день он съедает кол-во варенья равное сумме количества варенья в дня. за сколько дней он съест к грамм варенья? паскаль 10 класс

Ответ:
11715
11715
02.08.2020 17:27
Var k,k1,k2,kn,n,s:integer;
begin
write('k = ');
readln(k);
k1:=100; 
k2:=100;
s:=k1+k2;
if k<=k1 then n:=1 else n:=2;
while s<k do
 begin
 n:=n+1;
 kn:=k1+k2;
 s:=s+kn;
 k1:=k2;
 k2:=kn;
 end; 
writeln('n = ',n);
end.

Пример:
k = 1100
n = 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?