В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
marinamashkina2
marinamashkina2
25.06.2021 20:22 •  Информатика

Заполните массив, состоящий из 20 элементов, случайными целыми от 15 до 100. найдите минимальный элемент из элементов с чётными значениями.

Ответ:
KinezyOldside
KinezyOldside
11.08.2020 22:43

Объяснение:

program EvenMinimum;

var

a : array [1..20] of integer;

i,min: integer;

begin

   for i:= 1 to 20 do a[i]:=random(85)+15;

   writeln('Default array:');

   for i:=1 to 20 do write(a[i],' ');

   writeln();

   for i:=1 to 20 do if a[i] mod 2 = 0 then min:=a[i];

   for i:=1 to 20 do if (a[i] < min) and (a[i] mod 2 = 0) then min:=a[i];

   writeln('Even minimum in this array is :', min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?