В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
malinasch
malinasch
11.12.2022 02:31 •  Информатика

Нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями

Ответ:
карина1543
карина1543
02.08.2020 16:51
Не понял смысл задачи. 
Написал, вывод номера элементов равных 0.
Нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находи
0,0(0 оценок)
Ответ:
nastyaxa12oziu9w
nastyaxa12oziu9w
02.08.2020 16:51
#include <stdio.h>#include<stdlib.h>
int main(void){    int mas[16]; //массив со случайными числами    int i; //счетчик
    //заполнение массива случайными числами    for(i=0; i<16; i++)    mas[i] = -20+rand()%20;    printf("ishodny massiv");    for(i=0;i<16;i++)        printf("%d,",mas[i]);    printf("\n");
    printf("nomera elementov massiva ravnih nulu");    for(i=0;i<16;i++)    if (mas[i]==0) printf("%d",i+1);
return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?