Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Amina0807
23.08.2020 15:57 •
Информатика
Кто понимает паскаль, обращаюсь к вам! нужна ваша ! составьте программу, которая выводит все символы до первого многоточия и программу, которая заменяет каждое многоточие точкой и каждый пробел точкой.
Ответ:
Sveta1100
09.08.2020 11:48
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
var p:=Pos('...',s);
if p>0 then Writeln(Copy(s,1,p-1))
end.
Пример
> Это такая... тестовая... строка
Это такая
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
Writeln(s.Replace('...','.').Replace(' ','.'))
end.
Пример
> Это такая... тестовая строка, надуманная...
Это.такая..тестовая.строка,.надуманная.
0,0
(0 оценок)
Популярные вопросы: Информатика
Hurakan
15.09.2020 05:15
8. в каком случае удобнее использовать структуру дерево ? a) для указания частей автомобиля и взаимосвязи между нимиb) при перечислении признаков нескольких цветов c) для отображения...
аааааа102
31.03.2021 17:32
Создать призентацию на тему (while) ( файл прекрепить)...
flag4
05.06.2022 05:54
Посчитать сумму элементов находящихся на главной диагонали. паскаль...
olgavish761
01.01.2021 05:49
574,03 переведите в двоичную, восьмеричную и шестнадцатеричную системы счисления....
лимпоьип
29.02.2020 14:06
Жили- были клавиатура, монитор, процессор, мышь . жили они дружно, пока не возник у них спор кто главнее...
VarDim126
29.02.2020 14:06
Для данных адресов определите число компьютеров в сети: 192.168.104.109/30 172.16.12.12/29 193.25.5.136/28 10.10.40.15/27 92.60.65.180/26 118.212.123.1/24 как вы считали !...
Natasha183038
29.02.2020 14:06
Дайте объектам общее имя бумага диск камень берёста пергамент(какой вид информации? 15 )...
AjdanaLife
29.02.2020 14:06
Напишите программу (в паскаль) для функции у=х(в кубе)-1 на интервале [-1,3] с шагом 0.2 на трех разных циклах (до,пока,для)...
aishaolzhas
24.10.2020 11:51
6. вычислить площадь круга и длину окружности по введенному значению радиуса. 7. вычислить площадь s и периметр l эллипса по введенным значениям полуосей a и b:...
LizaIsaeva197
24.10.2020 11:51
с 3 . они весьма легкие, но сейчас уже не имею не возможности, не сил их выполнять, ибо комп вообще весьма далеко. буду за решения! программа в pascale 1. дано n целых чисел....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
var p:=Pos('...',s);
if p>0 then Writeln(Copy(s,1,p-1))
end.
Пример
> Это такая... тестовая... строка
Это такая
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
Writeln(s.Replace('...','.').Replace(' ','.'))
end.
Пример
> Это такая... тестовая строка, надуманная...
Это.такая..тестовая.строка,.надуманная.