В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kristina1861
kristina1861
25.01.2022 12:02 •  Информатика

Написать программу для abc паскаль. нужно сделать так, чтобы программа в ответе выдала xoxoxoxoxo, но при этом мы указываем сколько должно быть столбцов, сколько рядов. должна получиться шахматная доска. 10 класс program ksenia и т.д. 39 ! больше нет(

Ответ:
aliona123456789
aliona123456789
04.10.2020 16:04
Var n,m,i,j:integer;
begin
write('n = ');
readln(n);
write('m = ');
readln(m);
for i:=1 to n div 2 do
 begin
 for j:=1 to m div 2 do write('xo');
 if m mod 2 = 1 then write('x');
 writeln;
 for j:=1 to m div 2 do write('ox');
 if m mod 2 = 1 then write('o');
 writeln;
 end;
if n mod 2 = 1 then
 begin
 for j:=1 to m div 2 do write('xo');
 if m mod 2 = 1 then write('x');
 writeln;
 end;
end.

Пример:
n = 3
m = 5
xoxox
oxoxo
xoxox
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?