Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Milagrosrr
29.01.2021 01:28 •
Информатика
Используя подпрограмму-функцию , вычисляющую нод двух чисел , составьте подпрограмму-функцию для вычисления нод трех целых чисел . !
Ответ:
ormnjkfgfff
04.10.2020 14:46
// PascalABC.NET 3.2, сборка 1346 от 25.11.2016
// Внимание! Если программа не работает, обновите её версию!
function gcd(a,b:integer):integer;
begin
while b<>0 do
begin
a:=a mod b;
(a,b):=(b,a);
end;
Result:=a
end;
function gcd3(a,b,c:integer):=gcd(gcd(a,b),c);
begin
Writeln('НОД(138,48,312)=',gcd3(138,48,312))
end.
Пример
НОД(138,48,312)=6
0,0
(0 оценок)
Популярные вопросы: Информатика
Sudzuky
22.12.2022 03:29
Написать программу на c++ дана символьная строка, представляющая собой запись натурального числа в р-ичной системе счисления (2 ≤ р ≤ 9). составить программу перевода...
alekandra78zubo
22.12.2022 03:29
Составьте свой код и что закодирована...
Зайка20005
09.05.2023 16:38
Сочинение по информатике для 5 класса по теме комп нашей жизни...
KeKsickON
06.08.2022 03:19
1. на чём делались записи в древней индии? 2. чем писали в древней индии? 3. как выглядела древнеиндийская книга (описание)? 4. как называются цифры, которые мы используем?...
kuro4
06.12.2021 15:44
Заранее . какие компьютерные сети существуют? 1.локальные 2.компьютерные 3. 4.виртуальные какие локальные сети существуют? 1.одноранговые 2.многоранговые 3. 4.разные...
kmidakova
06.12.2021 15:44
Сканируется цветное изображение размером 10 х 10 см. разрешающая сканера _ 1200 х 1200 dpi, глубина цвета - 24 бита. какой информационный объем будет иметь полученный...
дибилон1
06.12.2021 15:44
Программирование в паскаль изменить программу которая ниже так, чтобы в ней подсчитывалось и выдавалось ! ! 3 ответа, a не 3 разные программы а) количество цифр числа;...
seliza415
21.12.2022 07:07
Дано натуральное число. верно ли, что сумма его чисел больше k, а само число четное?...
диана2440
21.12.2022 07:07
Определить объем памяти в мегабайтах для хранения цифрового стереоаудиофайла, время звучания которого составляет 2 минуты при частоте дискретизации 36 кгц и глубине...
Biglok
21.12.2022 07:07
По теме массив №1 дан массив состоящий из 10 вещественных чисел. преобразовать элементы массива , стоящие на чётных местах, уменьшив их вдвое. №2 сформировать массив...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите её версию!
function gcd(a,b:integer):integer;
begin
while b<>0 do
begin
a:=a mod b;
(a,b):=(b,a);
end;
Result:=a
end;
function gcd3(a,b,c:integer):=gcd(gcd(a,b),c);
begin
Writeln('НОД(138,48,312)=',gcd3(138,48,312))
end.
Пример
НОД(138,48,312)=6