В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sudzuky
Sudzuky
22.12.2022 03:29 •  Информатика

Написать программу на c++ дана символьная строка, представляющая собой запись натурального числа в р-ичной системе счисления (2 ≤ р ≤ 9). составить программу перевода этого числа в десятичную систему счисления. используя рекурсию. заранее )

Ответ:
Noziks4
Noziks4
02.10.2020 23:35
//перевод числа из системы исчисления
//с основанием от 2 до 9 в десятичную
 #include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
  int pss(char sr[80], int i, int osn)
  { 
    static int s;
    char ch=sr[i-1];
    if (i==strlen(sr)) s=1;
    s=s*osn;
    if (1<i) return (atoi(&ch)+pss(sr,i-1,osn)*osn);
    else return (atoi(&ch)); 
 }
int main(int argc, char** argv)
 { 
    int osn=0;
    char st[80];
    cout<<" задайте основание (от 2 до 9)  ";
    cin>>osn;  cout<<endl;
    cout<<"число:  "; cin>>st;   cout<<endl;
    cout<<"в десятичной системе:  "
     <<pss(st,strlen(st),osn);
    return(0);
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?