В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты.результат выводится в строку. в pascal abc

Ответ:
ммммм89
ммммм89
04.10.2020 13:00
Var
b:array[1..5] of real;
i:integer;
begin
for i:=1 to 5 do begin
write('Введите размер ',i,'-го файла в байтах: ');
readln(a[i]);
end;
for i:=1 to 5 do
if a[i]>1024 then a[i]:=a[i]/1024;
for i:=1 to 5 do
write(a[i]:4:1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?