В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Mtaraska
Mtaraska
31.03.2022 06:38 •  Информатика

Написать программу на языке с++. дано натурально число а в десятичной системе счисления. если все цифры числа а различные, то вывести на экран сообщение "да", иначе - сообщение "нет".

Ответ:
misha223414
misha223414
04.10.2020 11:13
#include <iostream>
using namespace std;

int main()
{
    int a;
    int k[9];
    bool f = true;
    cout << "a = ", cin >> a, cout << "\n";
    for (int i=0; i<10; i++) k[i]=0;
    while (a>0){
    k[a % 10]++;
    a = a / 10;
    }
    for (int i=0; i<10; i++){
    if (k[i]>1) f = false;
    }
    if (f) cout << "Да" << "\n";
    else cout << "Нет" << "\n";
    return 0;
}

Пример:
a = 12523
Нет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?